Google repareert lek in Android maar half

Anroid-logoHet besturingssysteem voor Android-telefoons bevatte een lek, zo werd twee weken geleden ontdekt. Google heeft het lek gerepareerd, maar alleen voor de meest recente versies van Android. Volgens het Franse webblad Futura-Sciences zouden nog steeds zo’n 60% van de Android-telefoons kwetsbaar zijn  voor inbraak. Dat zou volgens Google te maken hebben met technische onoverkomenlijkheden.

Het lek zat ergens bij WebView, een toepassing om webpagina’s te bekijken en werd twee weken geleden ontdekt. Voor Android 4.4 (KitKat) en 5.0 (Lollipop) zijn ‘pleisters’ gemaakt, voor de eerdere versies niet. Volgens Googles eigen cijfers gebruikt het merendeel van de Android-gebruikers nog steeds oudere versies. Na dagen van stilzwijgen heeft Google bij ‘monde’ van zijn veiligheidsman Adrian Ludwig nu uitleg gegeven. “Alleen in Webkit staan al 5 miljoen coderegels en honderden ontwikkelaars voegen daar elke maand duizenden nieuwe aan toe. Dat betekent dat voor de reparatie aanzienlijke delen van die code moeten worden veranderd voor oudere versies van Webkit. Het is niet goed mogelijk daar volledige veiligheid voor te creëren.” Volgens hem betekent dat niet dat Google de gebruikers van ouder versies in de kou laat staan. Er zouden mogelijkheden zijn de makkes van  het geconstateerde lek te omzeilen zonder dat ze meteen hoeven over te schakelen op KitKat of Lollipop. De eerste mogelijkheid is een websurfer te gebruiken die via Google Play wordt onderhouden, zoals Chrome of Firefox. In het algemeen raadt Ludwig aan alleen toepassingen te gebruiken die een goede naam hebben op het gebied van digitale veiligheid. Wat WebView betreft. De gebruiker zou toepassingen moeten gebruiken die niet in WebView laden en die uit betrouwbare bronnen stammen.

Bron: Futura-Sciences

Geef een antwoord

Het e-mailadres wordt niet gepubliceerd.

Deze site gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.