Ook Linux blijkt een bluetoothprobleem te hebben (gehad)

Linuxlogo

Linuxlogo

Google en Intel hebben een Bluetoothfout ontdekt in het alternatieve besturingssysteem Linux, dat ze BleedingTooth hebben genoemd (heel geinig). Je zou via die kwetsbaarheid toegang hebben kunnen krijgen op een Linux-machine zonder dat de gebruiker daar iets van zou hebben gemerkt. Het lek schijnt inmiddels gedicht te zijn (vooropgesteld dat je de laatste versie hebt geladen).Bluetooth is nogal eens de klos. Googlemedewerker Andy Nguyen, de onthuller op Twitter, gaf geen bijzonderheden, maar beloofde er in zijn bijdrage aan het Googleblog op terug te komen. In een video liet hij zien hoe je op het belaagde rekentuig een programma kon starten zonder medewerking van de eigenaar van dat apparaat.

Het lek zit op het niveau BlueZ het protocol dat Bluetooth gebruikt voor Linux. Het gaat om Linux-computers (er zijn diverse Linux-versies in omloop, zoals Ubuntu) maar ook voor met het web verbonden apparaten.

Intel

Inmiddels heeft Intel een reparatie voorgesteld. Het Amerikaanse chipsbedrijf schat de ernst van het lek in op 8,3 (van de 10). Via de kwetsbaarheid is de aanvaller in staat machtigingen te veranderen of informatie te stelen. Ook zou het lek massa-aanvallen mogelijk maken. Linux stelt voor aan de gebruikers over te stappen op versie 5.10 van Linux (hoe zich dat verhoudt in de verschillende distributies van Linux weet ik niet; as). De met het web verbonden apparaten worden zelden bijgewerkt en daar blijft het dit probleem dan ook bestaan.

Bron: Futura-Sciences

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.